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1. Overview 
Numbering in Word is difficult to understand because Word attempts to hide 
�complexity� from us. In many cases, it provides insufficient detail in the explanation 
of features. Regrettably, a simplistic explanation does not help understanding of a 
complex subject. It fills our heads with loose ends, which makes the problem worse! 

Let me warn you: this subject is a real brain-breaker. You can use Word very 
successfully and professionally without ever knowing or understanding this stuff. I 
wrote it for the real masochists among us who just have to know how it works.  

Do not let me lead you into a headache under false pretences: this FAQ is not going 
to tell you how to fix a document that contains broken numbering. It simply explains 
how the numbering works: this is valuable information if you work with Word a lot, 
and by understanding it, you can often work out how to fix a document. However, 
this FAQ is not going to tell you how. (For a discussion of fixes, see: How to cure 
Word's List Numbering with a dose of VBA). 

http://www.mvps.org/word/FAQs/Numbering/CureListNumbering.htm
http://www.mvps.org/word/FAQs/Numbering/CureListNumbering.htm
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2. File formats and structures 
Before we can begin, we need to know that there are four different file formats 
produced by products named Microsoft Word. Even though 16 products all used the 
�.doc� file extension, there are actually only four major file formats. Within each, 
there are several minor variations adding new bits. However, the four main 
underlying structures of the saved files determine how numbering behaves in the 
product, and what goes wrong with it. 

The four major file formats are: 

• Word for DOS 

• Word for Windows 1 and 2 and Mac Word 4 and 5 

• Word 6 and 95 and Mac Word 6 

• Word 97, 98 and 2000. 

Within these formats, there are two basic �structures.� The command-stream 
structure, and the OLE Container structure. 

2.1 Command-stream Formats 
Word for DOS and the first two versions of Word for Windows produced command-
stream file formats. Their files contain ASCII text and printer commands, in the order 
Word will send them to the printer. It�s a very simple format, and very robust. It�s... 
ummm... the format WordPerfect uses .... 

In these formats, the numbering exists in the text as real text and remains stable once 
created. Unfortunately, people rarely use these versions of Word these days. 

There�s no real point in describing the command-stream format product numbering. 
You use it, it works, it doesn�t break. Ahhhh... memories.... 

2.2 OLE Container Formats 
Word versions 6 and above produce OLE container formats. The file is a nested 
series of containers like Chinese Eggs. For example, each paragraph is a container of 
characters. Each section break is a container of paragraphs. Each document is a 
container of section breaks. 

Each container contains "something" (it may be a stream of characters, a set of 
drawing objects, or a binary object). The container also contains one or more 
�pointers� that connect it with property tables that determine the formatting and 
behaviour of the contained "something."  
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In Word versions 6 and higher, numbering is expressed as a property, a little 
container that contains a marker to say where in the text it is to print, and a pointer 
to an entry in a list of numbering formats that determines what kind of number it is, 
and how it increments. It�s important to our understanding to learn that this 
property does not contain the number text. Word fills in the number text itself just 
before it displays or prints the document. 
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3. Multiple Kinds of Numbering 
In the container formats, many different items can have numbering, and Word tends 
to treat them as different things. There are three different kinds: 

• Fields 

• Simple Lists 

• Outlines  

The �kinds� determine the behaviour of the three types. It may be worth noting that 
in Word versions 6 and above, a bulleted list and a numbered list are actually the 
same thing: only the �number format� is different. 

The following pages explain what the three kinds of numbering are, and the 
variations within each kind. 

3.1 Field Numbering 
Field-based numbering is the simplest and the most robust. Pages, Captions and 
Footnotes are examples of numbering done with fields. 

A field in a Word document is simply a placeholder that contains �the instructions for 
working out what should go here,� rather than the text itself. In this case, it contains 
the instructions for displaying and incrementing a set of numbers. A field is simply a 
small section of computer code embedded in a special container that tells Word to 
interpret the contents as computer instruction code instead of text. 

Word automatically inserts and maintains the fields for some forms of field-based 
numbering. The most commonly used numbering fields are pages, number of pages 
(page x of y) and footnotes. 

3.1.1 Captions 
Captions are a special case: if you use Word�s Insert Caption command, it inserts the 
fields for you, but the field itself is a good old-fashioned SEQ(uence) field, and some 
people prefer to insert them manually so they have complete control over the 
formatting and incrementing. 

A SEQ field can belong to only one sequence and it can produce only one level of 
numbering. You can number your headings using SEQ fields: if you do, you have to 
define a named sequence for each level of numbering. You also need to handle your 
own re-setting of each level when a higher level occurs. 

Field-based numbering is very stable and rugged, but a little fiddly and complex to 
use or maintain. Many professional writers such as technical writers use field-based 
numbering exclusively, because of its stability and ruggedness. They can export or 
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import documents containing field-based numbering to any of the Word file formats. 
They can convert the text backwards and forwards from Word 6, 95, 97, 98 and 2000 
as many times as they like, and the field-based numbering will always be correct. 

3.1.2 Clause Numbering 
Legal clause numbering requires that a single paragraph contains more than one 
number. Word 97 and 2000 introduced a new field called the LISTNUM field, 
designed especially for this. Regrettably, it will not down-convert to versions below 
Word 97, unless you unlink all the fields (press Ctrl+A followed by Ctrl+Shift+F9) 
prior to saving in Word 6/95 (or earlier) format. 

For clause numbering, you should stick to the AUTONUM field unless you are sure 
the documents will never needed to be edited in an earlier version of Word than 
Word 97 . 

3.1.3 Page x of y 
Word can automatically produce �page x of y� page numbering. Word performs this 
numbering with a pair of automatically inserted fields. Unfortunately, one of the 
fields has had a notorious bug in it since Word 6: you can end up with a sequence 
such as �page 1 of 1, page 2 of 2, page 3 of 3 ...� where the second part of the page x 
of y does not update correctly. The bug is actually in Word�s pagination algorithm. 
Word makes up the print image of the page before it has finished paginating the 
document, so it really doesn�t yet know how many pages there are ... Service Release 
1 for Word 2000 finally fixed the bug. See separate article Page x of y displays or 
prints as Page 1 of 1, Page 2 of 2 etc. for some workarounds for earlier versions.  

Technical writers rarely use �page x of y�, and where they do, they work-around the 
bug by constructing page x of y manually using a bookmark on the last page of the 
document and a cross-reference to its page number. 

3.2 List Numbering 
List-based numbering is simple to use, but very difficult to understand or fix. But 
wait... it gets worse: it is essential to understand list-based numbering before you can 
understand Outline Numbering. And that�s... ummmm ... awful! 

Common examples of list-based numbering are paragraphs and footnotes. 
Paragraphs can be numbered lists, but footnotes are always simple lists. 

http://www.mvps.org/word/FAQs/ApplicationErrors/PageXofY.htm
http://www.mvps.org/word/FAQs/ApplicationErrors/PageXofY.htm
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We all know what a �shopping list� is. It�s a list of names of products and the 
number you need to buy. OK, in Word a Numbered List is a list of paragraphs and 
the kind of number to put on each of them. If you were to examine the code 
internally, you would see an HTML-like structure: 
Begin List Definition 
 List Definition 
Begin Ordered List 
 List item 
 List item 
 List item 
 ... 
End Ordered List 

The whole key to the idea is that a list has a definition, a beginning, one or more 
items in the list, and an end. The most important distinguishing feature of �List 
Numbering� is that in a list, there can be only one level of numbering. Numbering 
levels are explained in the Outline Numbering pages. 

In a simple numbered list, a definition says �List number 23 is a sequence of Arabic 
numerals starting at 1, incrementing by 1, indented 3cm, and formatted in 12-point 
Times New Roman bold.� This definition is a List Template stored at the end of the 
document (hidden in the Default Section Break that is contained in the last 
paragraph mark). 

3.2.1 List Galleries 
Just for completeness, there are three kinds of list template: bulleted lists, numbered 
lists and outline numbered lists. These three types are collectively stored in three list 
galleries. A document always has three list galleries, whether or not the document 
contains any numbering. All three are stored in the default section break. The 
Format>Bullets and Numbering command shows you the first seven formats in 
each of the three list galleries. 

3.2.2 Default List Templates 
Word has a set of factory-default list templates built in. The three supplied list 
galleries each contain seven pre-set formats. These settings are hard-coded into 
Word. 

If you use the Format>Bullets and Numbering command, you see a Reset button on 
the dialog. This resets the selected list template to its factory default. We often ask 
people to do this as a preliminary step when trying to fix numbering. It restores each 
list template to a known good state. 
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3.2.3 Applied List Templates 
Because you can customise your list templates, the list templates you actually apply 
in a document often bear no relation to the list templates displayed in the 
Format>Bullets and Numbering command. 

Unfortunately, Word can have literally several hundreds of list definitions in a single 
document. Some or all of these may be �applied� to the text. The Format>Bullets and 
Numbering command can show you only the seven most-recently used in each of 
the three categories. 

3.3 Simple Lists 
Now, somewhere in the document, let�s find a sequence of paragraphs in a 
numbered list. Let�s say there are five of them, and they are paragraphs 43 to 48 in 
the document. Each of them has a tag indicating that it is a member of a list, and a 
pointer to list template 23, which formats that list. 

Now for the exciting bit: There can be more than one list in the document. �Of course 
there can,� you�re thinking. �Any technical manual has lots of little procedures 
expressed as numbered steps. Maybe five to seven items in each, and maybe one list 
every couple of pages.� 

Oh if only it were that simple... 

In Word, you can indeed have multiple lists. However, each �list� can have more 
than two �ends.� That sounds absurd, right? That�s because it is... 

Let�s take a typical technical procedure: ten pages and six sets of numbered steps. 
The first three sets of numbered steps are all members of the same list. The list 
restarts at �1� three times: at the first paragraph of each of the three sets of numbered 
steps. The second three sets of numbered steps are also all members of the same list. 
Again, they each restart at �1� on the first paragraph of each set of numbered steps. 
To Word, that document contains two lists, not six. 

The key distinction I am making is that the thing Word calls a numbered list is a 
larger structure than that which you or I know as a numbered list. Word considers a 
numbered list to be what you or I might describe as a �family� of numbered lists. 

3.3.1 Illustration of Simple Lists 
Think of a sporting goods shop that sells billiard balls. On one shelf, it has several 
boxes of balls by one manufacturer. Each ball has a number painted on it, as billiard-
balls must have. On another shelf, the shop has more boxes of balls by a different 
manufacturer. Moreover, on a third shelf, three boxes by yet another manufacturer. 
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What you and I call a �numbered list� is one box of balls. Microsoft Word uses the 
name �list� for the entire shelf. Microsoft has never been shy about changing the 
English language to suit itself...  

There may be several shelves of balls in the shop. Each set of numbered steps in the 
document may be a member of a different list. Or there may be only one shelf. Each 
numbered list in the document may be a member of the same list. 

Unfortunately, that last case is unlikely to be true if we have a document that needs 
fixing. There is likely to be quite a large number of lists in the document. There�s a 
celebrated bug, reported in the Microsoft Knowledge Base, which explains that 
things get a bit uncertain when a document contains more than 200 list templates... 

But it can get worse... 

Any given paragraph in the document may be a member of any of the lists. If we 
have seven paragraphs numbered 1 through 7, there is no guarantee that they are all 
members of the same list. They could each be a member of a different list: one list 
starts at �1�, the next starts at �2�, the next starts at �3� ... you get the idea... 

Oh, but it can get worse... 

How can we tell which list a particular paragraph resides in? Sigh... we can�t, unless 
we use VBA. Short of using Word 2000 to save the document to HTML and reading 
the code, there is no way to tell which list a particular paragraph or set of paragraphs 
currently resides in. We can make some guesses, and in the FAQ about fixing 
numbering, we will tell you how to improve the accuracy of your guesses, and how 
to ensure that a given set of paragraphs belongs to a specified list. However, short of 
saving the document out to HTML and reading the code, there is no way to discover 
what is wrong. 

3.4 Outline Numbering 
The most common form of Outline List is Heading Numbering. We often see this in 
technical, engineering and academic documents. In legal documents, body text 
paragraphs are frequently outline-numbered. 

An Outline List is a nested set of nine lists.  

The brain-breaking feature of Outline Lists is that everything I said about �simple� 
lists is true...multiplied by nine! 

All the complexities of the Numbered list also occur in Outline Numbered Lists. 
There can be multiple lists in a document, or only one. Each list can restart multiple 
times or only once. 
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I�ll type this slowly so we can all follow... an Outline List has more than one level of 
numbering, and each of the lower levels numbers independently to, but inherits 
from, its higher levels. The following is an outline numbered list: 

Heading 1 
Heading 1.1 
Heading 1.2 

Heading 1.2.1 
Heading 1.2.2 

Heading 1.3 
Heading 1.3.1 

Heading 2 

No, I typed those out by hand: there�s no way I could send that sequence across the 
Internet as Word numbering: if I tried, I have no idea what you would see! Notice 
there are three �levels� of numbering in the list. 

Item 1 and Item 2 are both members of Level 1. Items 1.1, 1.2, and 1.3 are members of 
level 2. Items 1.2.1, 1.2.2 and 1.3.1 are members of level 3. 

An Outline List has an extra property that simple List Numbered lists do not have: 
the paragraph�s level. Actually, the level property exists in the simple lists, but is 
always set to 1 and ignored. In an outline numbered list template the level is an 
integer between 1 and 9 that determines the paragraph�s level in the numbering 
scheme. This list level operates independently of the style and controls the number 
formatting. This is how legal documents can have multi-level lists in which all the 
paragraphs are formatted with the Normal style. 

Each of the levels of an outline list can number in a different sequence, and each level 
can have a different ordinal digit. The ordinal digit is a �number� to you and I, 
although you can specify a letter; or in a bulleted list, a character. 

To fully appreciate this horror, you need to consider the following: 

1. The first item 
2. The second item 

a. The first sub-item 
b. The second sub-item 

i. A sub-sub-item 
c. Another sub-item 

3. Another top-level item 

The above example demonstrates three of the levels of a default outline list. 
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In the example, there are seven paragraphs. They may all be members of the same 
list template, or they could have more than one list templates applied. Each 
paragraph could be attached to a different list template.  

When I prepared the example, it had only one style applied. However, there could be 
three. The list template may associate a single style with all nine levels, or one style 
for each level, or no style at all (which means it could be applied over the top of any 
style(s)). 

Of course, if some or all of the paragraphs are assigned different list templates, the 
actual style definitions applied become close to random. A Word document tends to 
crash if the number of list templates in a single list gallery exceeds 256, so we have 
potentially 2,304 combinations of formatting for each list. In a 300-page manual with 
a list on each page, that�s more than half a million differences in the numbering 
within a single document. In a document that is supposed to follow the company�s 
standard style guide. 

Now you can understand why MVPs often advise people simply to remove all the 
numbering from a document and start again: the complexities far exceed the capacity 
of a human being to work with them. 
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4. Applying Numbering 
Now we�ve busted our brains trying to understand how numbering works, we also 
need to think about how to apply it the document. The exact method by which you 
apply numbering has a dramatic effect on how stable it is and what goes wrong with 
it. 

4.1 Numbering Button 
One problem we run into is the List Number Default button on the Formatting 
toolbar. This is normally called the Numbering button.  

In previous versions of Word, it always applied a predefined list numbering format. 
In Word 2000, this was changed. It now applies an outline list template, and the list 
template it applies is the one used most-recently by the particular user-ID on that 
particular computer. 

If you select ten paragraphs in Word 2000 and click the Numbering button, the list 
will be an Outline list by default. There is no indication of this, but each paragraph 
has become a member of a list that contains nine levels. To change levels: 

• If, on the Edit tab of the Tools + Options dialog, you have the Tabs and Backspace 
set left indent checkbox ticked, you can change levels by placing your insertion 
point at the beginning of the paragraph, just after the number, and hit Tab to go 
down a level, or Shift/Tab to go up a level. Most people don�t know this, or why 
their numbering keeps changing. Exciting, isn�t it? 

• Fortunately the above option can be turned off and most seasoned Word users do 
turn it off. Corporate users (should) have it turned off for them (this is very 
simple to achieve using an AutoExec macro in an Addin). 

• If you have the Tabs and Backspace set left indent checkbox turned off, you can 
change levels by clicking anywhere in the paragraph and pressing Alt/Shift/Left 
Arrow to go down a level or Alt/Shift/Right Arrow to up a level (these 
commends can be dragged onto the toolbar if desired - they are OutlinePromote 
and OutlineDemote, respectively). 

Let�s say I select some paragraphs and choose Format>Bullets and 
Numbering>Numbered and choose one of the list templates. This will make the list 
template I chose my �Default�. From then on, each time I click that button on that 
computer using that user-ID, I will apply exactly the same list template. If I have 
gone further and defined that list template to associate with a style, whenever I click 
that button, the list template and the style will both be applied. 

However, if I take the document home, and apply some numbering from there, the 
numbering applied by that button will be the default list template on that machine. It 
will be different: it may also apply a different style. If another user gets hold of the 
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document, the numbering they apply will be different again. Yet all three times the 
users hit exactly the same button whenever they wanted numbering! 

4.2 Direct numbering 
Numbering can be applied directly to paragraphs, just as a font or indent can be. 
This is known as direct formatting numbering. If you select a paragraph or set of 
paragraphs and click the Numbering button on the toolbar, you will get direct 
numbering. If you use the Format>Bullets and Numbering command on the Format 
menu, you may get direct numbering, or you may get style-based numbering, 
depending upon which list template you choose. 

Direct numbering is by far the most common numbering seen in the corporate 
environment, and overwhelmingly the most troublesome and difficult to fix. 

When you apply direct numbering, the paragraph simply contains a pointer to a list 
template. If you copy the paragraph to another document the list template is copied 
to the other document as well, as a separate object, and added to the ones that are 
already in it. 

Consider a list of seven items. Five were created in the document. They have list 
template number 213 applied. Two were copied from another document. Two users 
edited the other document. The two paragraphs have list templates 7 and 128 
applied. The result now has list templates 213, 7 and 128 applied to the seven 
paragraphs. The seven paragraphs are actually members of three separate lists, and 
only one of them is applied anywhere else in the document. 

Similarly, if you move a paragraph from one list to another within the same 
document, you will get exactly the same problem; and you are likely to get 
"spaghetti numbering" as soon as you do so, as a result of the mixture of list 
templates present within a single sequence of consecutive paragraphs. (to give the 
simplest example, you might end up with a list numbered: 1,2,5,3,4). 

If other users apply or adjust any of these paragraphs, they will apply their own list 
template to some of them. Nevertheless, chances are the numbering will break before 
that happens. 

4.3 Style-based numbering 
A numbered or bulleted list may be associated with a style. It does not have to be. 
The recommended way, and the most stable approach to numbering, is to define it 
using Format>Style. If you do, your numbering will be associated with a style. 

When numbering is associated with a style, Word sets a pointer in the style 
definition that links the style with a list template in the document. The style does not 
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store the numbering list template; the style merely indicates which list template to 
use. 

This exposes us to the danger of circular references. If, say, your Heading 1 style 
points to Outline List Template 4, the list template can point to nine styles, one for 
each level of the list. In fact, one of the hard and fast rules of defining outline list 
templates is that you must never associate the same style with more than one level. 
Unfortunately, Word does not prevent this. 

In a corrupt document, you often find that Heading 1 points to one list template, 
Heading 2 to another, and Heading 3 to yet another. But each of the list templates 
have nine levels, so each list template points back at nine styles (a circular reference). 

4.4 Style-Template conflicts 
Where numbering is style-based, both the style and the numbering list template store 
indents, margins, and tabs. As does the paragraph the combination is applied to. It is 
possible for the measurements in the style to conflict with the indents in the list 
template. And for both to conflict with the measurements already applied as direct 
formatting to the paragraph.  

Direct tabs and indents applied to the paragraph will always override any others. 
The formatting of the list template will always override the style. If both of the above 
are absent, the indents and tabs come from the style. 

Whenever you define the formatting of a list template, it always overrides the 
settings of the underlying style. This is a bug. 

A second bug is that when you define list template formatting, it transposes some of 
the measurements. The paragraph has a left margin, an indent, and a first-line 
indent. The list template has no left margin, it has a position and a hanging indent. 
Whenever you adjust the formatting of a list template, it will transpose its hanging 
indent measurement into the style�s left margin setting. You need to remember to go 
back and correct the formatting of the style each time you adjust a list template. 

Recall that the style does not contain the list template formatting. This means that it 
is quite possible to have more than one style attached to the same list template. In 
amateur documents, it is quite common to have several styles with different names 
used for the same type of paragraph. They may all point to the same list template. Or 
they may each point to different list templates that may or may not have the same 
formatting. 

If multiple styles point to the same list template, this gets exciting when someone 
redefines one of the styles. The measurements will no longer suit one of the list 
templates, and things rapidly go down hill. It gets even more perplexing if you have 
multiple styles pointing to different list templates. You may redefine the list 
template: only some of the paragraphs come right. You may redefine a style: again, 
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only some of the paragraphs will follow. You need to hunt down all the styles and all 
the list templates and unify them all. 

The converse cannot be true: You cannot have multiple list templates in paragraphs 
formatted with the same style. This is why we recommend that you always apply list 
numbering with a style. If you always apply the same style name, you will always 
apply the same list template. 

4.5 Template conflicts 
There are two common causes of template conflicts. 

If individual users have different definitions for the various list templates involved, 
the numbering breaks each time a different user opens the document. I recommend 
that you orphan Normal style so that it is not used in the document, and ensure that 
none of the styles that contain numbering in the document are based upon it. This 
lessens the number of times you will suffer the problem. 

The second conflict occurs if any document with numbering is attached to its 
template with �Automatically update styles on open� set to ON. Each time you open 
the document, Word resets the style. This either conflicts with or resets the list 
template, and breaks the numbering. 
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5. Numbering in action 
Let�s take a simple technical manual: It has a TOC, Index, Five Chapters and 
numbered headings. That�s one outline numbered list so far.  

In the body, there are some footnotes: a numbered list. There are some numbered 
steps, also a numbered list. It also has two multi-level numbered lists, which in this 
case will be two separate outline lists. 

In the footer there is a Page x of y page number, and in the body, some figure 
captions. These are two field-based lists: one is automatic (using LISTNUM fields), 
the captions are manual (using SEQ fields). 

This is a simple example, so let�s stop there. The following pages will go through the 
various kinds and types of numbering in the document and explain some of the 
pitfalls. 

5.1 Page numbering 
Word produces page numbering with a simple built-in field that it automatically 
updates as it paginates. Page numbering is very stable and rarely gives trouble. 

It is worth mentioning that in Word, �pages� do not exist in the document file. Like a 
professional typesetter, Word makes up its pages on the fly when it displays or 
prints a document. Word uses measurements from the installed fonts and the 
installed printer driver to do this. It is almost impossible to get two machines so 
exactly similar that a document will paginate with exactly the same page breaks on 
each. Sometimes people complain that when they open the document on a different 
machine, some of the page numbers in the TOC or Index are �wrong�. They�re not: 
when the document is opened on the other machine, minute variations in set-up that 
do not show over a ten page memo will cause variations in the position of page 
breaks in a 1,000-page manual. If you remember to update the TOC and Index before 
you print, the problem corrects itself. 

The other classic cause of bad page numbering is multiple �sets� of page numbers in 
the document. There are two places you can add page numbers: to the �document�, 
or to the running Footers. If you use Insert>Page Numbers, you add the page 
numbers in little floating fields that sit in the drawing layer above the text layer. If 
you open View>Headers and Footers and click in a footer, then click the hash sign # 
you insert the page number field in the footer, on a section-by-section basis. 

Unfortunately, there�s nothing to stop you adding them in both places, and having 
them start at different numbers. If you find that the numbering is out for just one 
section of the document, this is a classic sign that you have conflicting sets of page 
numbers in the document. 
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5.2 Tables of contents 
The Table of contents (TOC) is not a Numbered List. It simply copies the text of the 
headings in page number order, including any numbering that may be applied. If the 
headings have numbers, the TOC generator copies those numbers. The generator 
automatically applies TOC Styles 1 to 9 to format the TOC. The generator sets the 
styles to Automatically Update, which enables it to automatically set their formatting 
according to hard-coded defaults chosen by the TOC format setting. If you want to 
prevent this, set your TOC format to �From Template�. Word will then leave the 
formatting of your TOC styles alone. 

Simple and stable: not much goes wrong with TOCs for this reason. The only catch is 
that the entire TOC is a field itself, and if you don�t know this, you can mangle it. 

The generator actually generates the page numbers in the TOC by inserting a hidden 
bookmark at every Heading in the document. In the TOC itself, Word 97 generates a 
hyperlinked PAGEREF field for each page number, referencing the appropriate 
heading (if you click on the page number it takes you to the Heading).  In Word 2000 
it generates a more complex hyperlinked field, which allows you to click on the text 
in the TOC to go to the referenced Heading. 

Either way, you can see these hyperlink fields by right-clicking any page number 
and selecting "Toggle Field Codes".  You can see the hidden bookmarks by selecting 
any Heading in the document, selecting Insert>Bookmark, and ticking the "Show 
Hidden Bookmarks" checkbox.  The hidden bookmark applied to the heading you 
are in will be selected in the dialog, and its name will tally with that in the relevant 
field in the TOC itself. 

When you update the TOC (by selecting it, pressing F9, and choosing "Update entire 
Table"), all the hidden bookmarks that have been applied to the Headings are 
deleted and recreated - you can see that their names have changed, if you look.  
However, prior to Word 97, the hidden bookmarks were not deleted when you 
regenerated the TOC; instead, a new set of bookmarks was created each time;  so you 
could very quickly end up with hundreds of redundant bookmarks, leading to a 
huge increase in file size and, frequently, to document corruption. 

You can convert the entire TOC to ordinary text. If you do, the styles remain applied 
and the entries are all converted to hard text. People sometimes do this to prevent 
document corruption. In Word 6, if you re-generated the TOC too many times, the 
document would corrupt, so people would convert the TOC to hard text to prevent 
this happening. This is no longer so necessary in Word 95 and above, but you may 
find it in up-converted documents. The problem with the technique is that when the 
document gets to a different computer, the page numbers in the TOC will be wrong. 

You will rarely see problems with TOC numbering. If you do, unless the user has 
manually typed the wrong numbers into the TOC, the problem exists in the body of 
the document, not in the TOC. If you regenerate the TOC, you remove any manually 
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typed numbers, unless they are in the body of the document. In fact, the TOC is an 
excellent device for looking for numbering problems in the body of the document. 
Since you have to check the TOC anyway before you publish, you might as well look 
for numbering problems while you are at it. 

5.3 Index 
The Index works in a similar way to the TOC (although unlike the TOC, the index 
contains no hyperlinks). Index styles 1 to 9 set the formatting, and the Index 
generator automatically applies them. The index generator copies the page numbers 
from the page number built-in counter Word maintains. Again, it is simple and 
stable.  

If you see bad numbers in the Index, it means the page numbering in the document 
is bad. Often, it is because the user has forgotten to suppress the display of hidden 
text before generating the Index. The hidden text throws various paragraphs onto the 
following page: when you print the book, the page numbers in the index don�t match 
those printed. A trap for young players... 

5.4 Chapter numbering 
There are several ways of applying Chapter Numbering. You can apply it as part of a 
style, or as direct formatting, or type it. 

By rights, the Chapter heading should be Heading 1 style, and the user should have 
used the list template that shows the word �Chapter� in its picture. If they did, the 
chapter numbers are part of the heading numbers outline numbered list template. 

Some people elect to type in the chapter number, particularly if the chapters are 
separate files. If they do this, they frequently forget to check the chapter numbers 
when they add a chapter. Gotcha! 

People working with multiple files sometimes use Heading 1 for the Chapter 
heading, but manually set its starting number. If you right-click the chapter title, 
immediately after the chapter number, you can set the Start-At number. This is a 
fertile source of bother. Any time the user updates the style, they must manually 
reset all the chapter numbers. If the chapter ever becomes part of a master document, 
the master document resets the chapter numbering each time a user opens the 
document. If the template is attached with Automatically Update Styles set, the 
chapter numbers are reset each time the document opens. 

If the chapter numbering is applied by direct formatting, odd corruptions are 
possible if you redefine the style upon which the numbering is based. The classic 
case is where the direct formatting list template is different from the list template 
associated with the styles. The cure is to remove all numbering and re-apply just one 
kind. 
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5.5 Heading numbering 
Heading Numbering is simply a list template in which levels 1 to 9 are attached to 
styles 1 to 9 (normally, Heading 1 through Heading 9). 

Heading numbering is more stable than other types because (as long as you define it 
correctly initially) it is usually a single list, and it almost never restarts. Where you 
get problems with heading numbering, remove it and re-apply it. This should re-
create it as a single list if it has become broken into pieces. 

You have to be looking for trouble to break heading numbering. Unfortunately, 
converting the document to a different format is �looking for trouble.� Converting 
between Word 6 or 95 and Word 97/98/2000/2001 is thrill seeking, and converting a 
document to or from WordPerfect is almost guaranteed to break it. 

In the default list templates seen in the Format>Bullets and Numbering dialog under 
the Outline Numbered tab, three of the samples show the word �heading� in their 
pictures. These list templates are automatically associated with the built-in heading 
styles Heading 1 through Heading 9. By default, Word�s built-in heading styles have 
list levels 1 to 9 assigned. It�s this list level that governs the operation of the heading 
outline numbering. 

There are three ways of applying heading numbering: with a style, by direct 
formatting, or typing. Professional writers tend to apply it with styles, corporate 
users tend to apply it as direct formatting. Users in trouble sometimes try to correct it 
by typing it. Any document that has ever been saved to a text-based format or to a 
format earlier than Word 6 will have hard-typed numbering throughout. 

If the numbering has been applied with styles, it is robust and unlikely to 
malfunction. Because each style can point at only one list template, all headings in 
the document are likely to be members of the same list. Text copied from other 
documents should assume the style definition of the destination document, and thus, 
become a member of the same list. 

When applying heading numbering, it pays to take great care that you use a default 
list template that is associated with the Heading styles. These list templates have 
special properties: they �know� that they belong on Headings. If you decide to use a 
different list template for heading numbering, you must first create your styles 1 
through nine, then assign each of the styles an outline level, and finally associate 
each level of your outline list template with a different style. It�s a lot of work, and 
it�s not worth it: Use the built-in Heading styles: the work has been done for you. 

You should apply heading numbering using Format>Style. 

Trouble may break out if the user starts fiddling around with the style definitions. 
They may associate the same style with more than one level in the list template. A 
classic example is to have Heading 1 associated with Level 1 (the chapters) and Level 
5 (the appendices). This was a recommended work-around for Appendix numbering 
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in Word 6 and 95, so you will often see it in up-converted documents. You need to 
reset the list template to cure this. 

A rare error, but a far more damaging one, is to have the same style associated with 
more than one level in a list. You often see this in corporate documents: the list 
template is simply cactus: remove and replace it.  

A variation on this is that various heading levels are members of different list 
templates. This is perhaps the most common spaghetti-numbering error in corporate 
documents. Both list templates are now corrupt: you have to remove both, reset both, 
and re-apply just one of them. 

5.5.1 Direct Formatting Headings 
If the numbering is applied as direct formatting, it should be applied from the first 
Heading 1 in the document, all the chapters should be in the same document, and 
the Chapter Titles should all be Heading 1 style. If the author follows these rules, all 
will be well. And pigs might fly... 

If you apply heading numbering using Format>Bullets and Numbering you apply it 
as direct formatting, which is not stable. The list template it is applied as direct 
formatting, but only to those paragraphs that currently have the built-in Heading 
styles applied. This updates the document�s internal style so that it points to the list 
template. However, paragraphs copied in from another document may not correctly 
accept the numbering, and if the style is re-applied from the template, the headings 
may lose their numbering, or the template numbering may conflict with the local 
numbering and corrupt the document. 

This can lead to a really nasty situation where you re-apply, for example, Heading 3. 
This sets the Heading 3 paragraphs in the document as members of a different list. 

Problems will occur when text is copied from another document. That text may or 
may not have heading numbering already applied. Even if it does, it cannot have the 
same list template applied. So some or all of the copied text may be in a different 
outline numbered template from the rest of the document. This is the beginning of 
the �spaghetti numbering� bug. In spaghetti numbering, one or more heading 
numbers are out of sequence, and try as you might, you cannot get all the headings 
to number correctly. 

If you catch it early, the cure is simple: remove the heading numbering, save the 
document and close it. Then re-open it, and re-apply the heading numbering from 
the first Heading 1 in the document. 
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5.6 Simple Lists 
If you apply numbering with Format>Bullets and Numbering, you can choose 
either a Numbered list or an Outline Numbered list. If you choose a Numbered list, 
your list will be a simple single-level list. 

A single-level list does not change its numbering style if the paragraph indent 
changes. There is only one level, and each paragraph in the list will have the same 
kind of number, regardless of the paragraph formatting. 

However, a typical manual may contain a list of numbered steps on each page. These 
may all be members of the same list they may each be members of a different list.  

If you select some paragraphs, format them with numbering, then choose 
Format>Bullets and Numbering, or right-clicks the list and chooses Bullets and 
Numbering, a dialog appears with two radio-button options: Continue Previous List 
and Restart Numbering. If you choose Continue Previous List, this list will be a 
member of the same list as the preceding list in the document that had that list 
template applied. If you choose Restart, you create a different list. 

When you start copying, pasting or moving paragraphs, you can move paragraphs 
from one list into another. This doesn�t matter if all the numbered lists in the 
document are members of the same list. If you have multiple lists, the moved 
paragraphs can retain membership of a different list. Some paragraphs in a set of 
numbered steps are not numbering in sequence with the others. You get Spaghetti 
Numbering.  

If you copy the paragraphs from a different document, they can�t be members of the 
same list as other paragraphs in the destination document, because their list is not in 
the document. Word�s answer is to copy their list template into the destination 
document with them and insert it into the list template gallery. If you then move 
some of these paragraphs around, you can produce some interesting effects. What 
you cannot do is guarantee that all numbered paragraphs with the List Number style 
will all be members of the same list and all number contiguously from top to bottom. 

5.7 Outline Lists 
On the Format>Bullets and Numbering>Outline Numbered dialog, the four 
samples that do not show the word �Heading� in their pictures are not, by default, 
associated with styles. 

These templates produce outline list paragraphs. We used to know such lists as 
multi-level numbered lists. You use the Promote and Demote buttons to change the 
levels of the paragraphs. When you do, you change both the numbering level and 
the indentation. 
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Unless you create them using styles, and define the styles using VBA, Outline- 
numbered list paragraphs will break pretty much every time you close the document 
unless you happen to be a highly-skilled user such as a technical writer who 
understands all the stuff you read here and bears it all in mind every minute they 
work! If you do that, the numbering will break only about half the time {grin}. 

When you define such a list using Customise, you get the choice of associating a 
different style with each of the nine levels, or associating just a single style with all 
levels. If you decide to associate only a single style, ensure that it has its level 
property set to �1�, and that it is associated with the first level. 

When a corporate user is creating numbering, they are likely to do it with either 
AutoFormatting or Format>Bullets and Numbering. 

AutoFormat converts the list format the user types into a Word numbered list. 
Unless the user is sufficiently accurate to type exactly the same format each time, 
AutoFormat tends to add a new list template each time the user creates a numbered 
list. 

In a major behind-the-scenes change, in Word 2000, Outline Numbering became the 
default type of numbering. In earlier versions, clicking the default �Numbering� 
button on the Formatting Toolbar would produce a Numbered list. It now produces 
an Outline Numbered List. You would never notice the difference if nothing ever 
went wrong. Unfortunately, things do go wrong, and when they do, the complexity 
of the problem is indescribable; made worse by the fact that you have no idea what is 
going on. 

Format>Bullets and Numbering invites you to select a numbered list each time. 
Most people will select the same list each time, so in a document produced with 
Format>Bullets and Numbering, the document is likely to contain just a single list. 
Each time you want a new numbered list, you select the format, then right-click the 
first item and choose the �Restart Numbering� option. The single list contains 
multiple restarts. 

If multiple users have edited the document, it is likely to contain both multiple lists 
and multiple restarts. Regardless of which technique each person employs. Each 
individual user�s numbering is different. Word stores its numbering formats in the 
Registry, so each user has their own. No two are ever the same. 

If multiple users use AutoFormat... well, you work it out! The results are pretty close 
to random. 

5.8 Footnotes 
Word automatically creates footnotes as list-based numbering. 

http://www.mvps.org/word/FAQs/Numbering/CureListNumbering.htm
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The number in the text is actually a cross-reference to the number of the footnote. 
Word automatically numbers the footnote paragraphs and creates the cross-reference 
when you insert the footnote. 

Footnote numbering tends to be very stable. Difficulty can arise when pasting text 
that contains footnotes from document to document, although it is rare. It is also 
possible to get problems with footnotes that have multiple references. Sometimes, 
the cross-reference field for one or more of the references gets broken and calls either 
in the wrong footnote or none at all. 

If a footnote appears on a different page from the page in which the footnote 
reference occurs, this is the result of a known bug; and the fix is to define the 
paragraph formatting of your body text to have exact line spacing. 

When fixing footnote numbering, you must first find out whether you are dealing 
with the original footnote reference or a subsequent cross-reference. If it is a cross-
reference, you can simply delete it and re-create it. If you delete the original footnote 
reference, you will also delete the footnote, so don�t do that. If your footnote 
numbers are out of sequence, chances are one or more of the references is not 
actually a footnote. To find out, double-click it: if it is a footnote, the footnote editing 
window opens, if it isn�t, nothing happens. 

5.9 Field numbers 
Captions and LISTNUM fields are examples of field-based numbering. 

In captions, the field is a simple SEQ field. A SEQ field can belong to only one 
sequence and it can produce only one level of numbering. You can make heading 
numbering using SEQ fields: if you do, you have to define a named sequence for 
each level of numbering. You also need to handle your own re-setting of each level 
when a higher level occurs. 

The SEQ field takes a �name� that identifies which list contains this particular SEQ 
field. For captions, that name must be �Caption.� When SEQ fields go wrong, it�s 
usually because you have forgotten to update them, or the list name is wrong. To 
update SEQ fields, select all the document text (Ctrl + a) and hit F9. 

LISTNUM fields are a much more advanced kind of field introduced in Word 97. 
They are a bit flighty, because Word maintains and automatically updates them. And 
there is a bug in the Help: it appears as though you can define various list names in a 
LISTNUM field the same way as you can in SEQ fields. In fact, you can�t: there are 
only three pre-defined list names: AUTONUM, AUTONUMOUT, and 
AUTONUMLGL. It also appears that you can control the formatting of a LISTNUM 
using switches: again: wrong! The name in the list name parameter controls the 
numbering formatting. Each of the three names has predefined formatting: what you 
see is what you get. 
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The LISTNUM field is a single field that generates nine levels of numbering. It reads 
the �level� property of the paragraph format to determine which level to display. 
You can have multiple LISTNUM fields within a paragraph: if you have, they 
number sequentially from the beginning of the paragraph. You can have multiple 
levels of LISTNUM field in a paragraph: if you select the LISTNUM field result and 
press the Indent or Outdent buttons, the level will change, overriding the level of the 
paragraph. This is the first place to look if a LISTNUM field won�t behave: once set, 
the hard-coded level set in the LISTNUM field does not change if you change the 
level of the containing paragraph. Reveal field codes and remove the level parameter 
to make it behave. 

Technical writers often use AUTONUMLGL fields to generate heading numbering. 
They are rock-solid stable and transportable across all versions of Word from Word 6 
to Word 2000. Microsoft makes concerted attempts in the Help to steer us away from 
these fields: instead suggesting that we should use Outline Numbered Lists or 
LISTNUM fields. Sorry, we�re not that silly! LISTNUM fields are not backwards 
compatible with Word versions earlier than Word 97. Most other word-processors 
haven�t a clue what to do with LISTNUM fields. Everything can handle 
AUTONUMLGL fields. Moreover, if Outline List Numbering was any good, you 
wouldn�t be reading all this! 

5.10 Professional issues 
For professional purposes, field-based numbering is the recommended method: you 
have complete control and it never breaks.  

However, it is impracticable, and thus silly, to introduce field-based numbering into 
the corporate workplace. It�s years since corporations stopped providing word-
processor training for their staff. Even if they were to do so, the Microsoft Word 
training available these days is so simplistic that it never gets anywhere near the 
professional-level features of Word such as field-based numbering. You should not 
expect corporate users to understand Word well enough to use field-based 
numbering. So you should very definitely expect a disaster if you send such people a 
document containing it: you will certainly get one. 

I did not leave the numbering samples in this FAQ as Word numbering to send to 
you: I can�t because I have no idea how the numbering will appear when you look at 
it: the numbering can change dramatically when your computer applies your local 
preferences to it. I prepared the example in Word 2000, then saved it in Word 2 for 
Windows format, closed it and re-opened the file. This is the simplest way to strip 
the numbering back to ordinary typed text that won�t change no matter where you 
display it. 

This is a major issue in Word numbering, and is the reason that corporations are 
reluctant to roll out the higher levels of Word (97, 98, 2000 and 2001). The numbering 
is simply not transportable from user to user, machine to machine, or office to office. 
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Since that is a fundamental requirement for corporate documents, many large 
corporations have gone no further than Word 95. Others have rolled back to 
WordPerfect 9. As yet, there are no alternatives we can offer you, other than the fix 
covered in How to cure Word's List Numbering with a dose of VBA). 

http://www.mvps.org/word/FAQs/Numbering/CureListNumbering.htm
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